Scylla Open Source 3.3.4

The ScyllaDB team announces the release of Scylla Open Source 3.3.4, a bugfix release of the Scylla 3.3 stable branch. Scylla Open Source 3.3.4, like all past and future 3.x.y releases, is backward compatible and supports rolling upgrades.

Note that the latest stable branch of Scylla Open Source is Scylla 4.0; you are encouraged to upgrade to it.

Related links:

Issues fixed in this release

  • Security: upgrade bundled gnutls library to version 3.6.14, to fix gnutls vulnerability CVE-2020-13777  #6627
  • Tooling: upgrade toolchain for gnutls 3.6.14 #6627
  • Tooling: nodetool status returns wrong IPv6 addresses #5808
  • AWS: Update enhanced networking supported instance list #6540
  • Stability: When a node fails during an ongoing node replace procedure, and then restarted with no data, parts of the token range might end up not assigned to any node #5172
  • Stability: potential use after free in storage service #6465
  • API: Scylla returns the wrong error code (0000 – server internal error) in response to trying to do authentication/authorization operations that involve a non-existing role. #6363

18 Jun 2020